随着WordPress 5.5的更新,默认情况下不再启用称为jquery-migrate的迁移工具。 这可能会导致某些主题或运行较旧代码的插件缺少功能或出现意外行为。

该插件用作临时解决方案,使您网站的迁移脚本能够为您的插件和主题作者提供更多的时间来更新和测试其代码。

随着WordPress 5.6的更新,包含的jQuery版本也已升级。 这意味着以前引起警告的旧代码现在可能会导致错误或完全停止工作。

一些不再起作用的功能将在幕后停止工作,而没有任何明显的问题。

该插件可以让您在一段时间内降级到jQuery的早期版本,但是作为站点管理员,我们建议您修复潜在的问题。

这个插件会在后台反复显示侦测到的jQuery兼容性问题,可以用Disable Admin Notices Individually插件隐藏。

整个WordPress主题与插件生态要完全脱离旧版jQuery(以及migrate)过度到新版jQuery库(3.5+)估计还需要较长时间。

习惯了React/Vue语境的程序员读者,是的,jQuery没死,它仍运行在全世界38%+的网站上。

发现错别字麻烦选中按Ctrl+Enter

类似文章

guest
0 Comments
Inline Feedbacks
View all comments